TomSynthAnatomy

person Registered User
Joined: Saturday, March 18, 2017
Last Seen: Saturday, March 18, 2017
Posts: 1
Comments
The apps must be updated to AB3. I beta test AB3 and some apps doesn't work yet properly with it because they use still the old AB2 standard.
Posts Votes